Usar iThemes Security con WP Rocket

WP Rocket es compatible con el plugin de seguridad iThemes Security.

iThemes Security tiene una opción para prevenir la modificación de los archivos de sistema (lo cual es una medida de seguridad razonable). Sin embargo, WP Rocket necesita permisos de escritura en el archivo .htaccess, wp-config.php y también necesita crear advanced-cache.php más las carpetas /cache y /wp-rocket-config. 

Los permisos de carpeta tendrían que estar configurados a 755, 775 o hasta 777 según la plataforma de hosting. Los permisos de archivos tendrían que estar a 644 (valor por defecto de WordPress).

Una vez instalado WP Rocket, asegúrate de haber apagado la opción System Files Protection de iThemes Security:

En caso de que la opción sea habilitada cuando activas WP Rocket, la caché no se activará y varás este mensaje de error: